Management Portal - Degraded Performance

Incident Report for EngageOne™ Video

Resolved

Normal service has been restored for the EngageOne Video Management Portal.
Posted Jan 03, 2018 - 13:41 GMT

Investigating

The EngageOne Video Management Portal is experiencing degraded performance. We are actively investigating the issue.
Posted Jan 03, 2018 - 13:33 GMT