EngageOne Video | Reported issue affecting services on the admin portal Environment

Incident Report for EngageOne™ Video

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 11:05 BST

Investigating

The Precisely EngageOne Video team are currently looking into an issue affecting the admin portal environment.

What happen:

Between 07:51 UTC and 08:32 UTC, customers experienced degraded or unavailable access to EngageOne Video Admin Portal. The problem originated in services provided by our cloud infrastructure provider, which caused networking and service disruptions for our deployment. Because Atlassian Statuspage was unavailable at the same time, we could not publish incident updates through our normal status page until the provider restored their service.

Customer impact:

All customers who tried to login to admin.engageone.video between 07:51 - 08:32 UTC were affected and could not log in to the admin portal. All video delivery environments were not affected by this and worked during the whole incident time.

Updates will follow throughout the issue to keep you informed of the incident. Should you require any additional information please contact software.support@precisely.com

Many thanks,

EngageOne Video Team
Posted Oct 20, 2025 - 11:04 BST
This incident affected: Management Portal (Director, Publishing system, User management, Deployment, Reporting).