Management Portal Login Issue

Incident Report for EngageOne™ Video

Resolved

This incident has been resolved.
Posted Oct 08, 2018 - 10:21 BST

Investigating

We are currently investigating an issue with logging in to the Management Portal.
Posted Oct 08, 2018 - 10:11 BST
This incident affected: Management Portal (Director, Publishing system, User management, Deployment, Reporting).